Apache Solr < 4.10.5 'plugin.js' XSS

Medium Nessus Network Monitor Plugin ID 8974

Synopsis

The remote web server contains a Java application that is affected by a persistent cross-site scripting (XSS) vulnerability.

Description

Versions of Apache Solr prior to 4.10.5 are affected by a persistent cross-site scripting vulnerability. Specifically, this affects the Plugin-View area in 'plugins.js' due to a failure to sanitize query histories before returning them to the user of the Solr administration panel. A remote, unauthenticated attacker can exploit this issue to execute arbitrary JavaScript within the context of a victim's browser, allowing the attacker to steal session information, log key strokes, and perform other malicious attacks.

Solution

Upgrade to Solr 4.10.5 or later.

See Also

http://seclists.org/oss-sec/2015/q1/850

https://issues.apache.org/jira/browse/SOLR-6738

Plugin Details

Severity: Medium

ID: 8974

Family: CGI

Published: 2015/10/15

Modified: 2016/02/16

Dependencies: 8967

Nessus ID: 82028

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:solr

Patch Publication Date: 2014/12/29

Vulnerability Publication Date: 2014/11/13

Exploitable With

Metasploit (linux/http/f5_icall_cmd.rb)

Reference Information

CVE: CVE-2014-3628

BID: 73129