WebGUI 7.9.x / 7.10.x <= 7.10.29 Search Field XSS

Medium Nessus Network Monitor Plugin ID 8890

Synopsis

The remote web server is running an outdated version of WebGUI which is affected by a cross-site scripting (XSS) vulnerability.

Description

All versions of WebGUI 7.9.x, and WebGUI versions 7.10.x prior to 7.10.30 are vulnerable to a cross-site scripting vulnerability. This flaw exists in '/style-underground/search' because the script does not validate input before returning it to users in error messages. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

No solution is available at this time.

See Also

https://www.webGUI.org

http://seclists.org/fulldisclosure/2015/Jan/79

http://www.nessus.org/u?00c484e5

Plugin Details

Severity: Medium

ID: 8890

Family: CGI

Published: 2016/02/25

Modified: 2016/02/25

Dependencies: 8633

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:U/RC:UR

CVSSv3

Base Score: 3

Temporal Score: 2.8

Vector: CVSS3#AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:U/RC:R

Vulnerability Information

CPE: cpe:/a:plainblack:webgui

Vulnerability Publication Date: 2015/01/17

Reference Information

CVE: CVE-2015-1564

BID: 72253