Moodle < 2.6 / 2.6.x < 2.6.7 / 2.7.x < 2.7.4 / 2.8.x < 2.8.2 Multiple Vulnerabilities
Medium Nessus Network Monitor Plugin ID 8725
SynopsisThe remote web server is hosting a web application that is vulnerable to multiple attack vectors.
DescriptionThe remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.6.x prior to 2.6.7, 2.7.x prior to 2.7.4, 2.8.x prior to 2.8.2, and all previous releases are exposed to the following vulnerabilities :
- An access bypass flaw affects the 'mod/lti/ajax.php' script related to missing capability checks. This may allow a remote attacker to search the list of registered tools. (MSA-15-0001 / CVE-2015-0211)
- A stored cross-site scripting (XSS) vulnerability in the Course Summary section. Specifically, this affects the course request pending approval page, 'course/pending.php', because it does not sanitize user-supplied input before displaying it to the course manager. (MSA-15-0002 / CVE-2015-0212)
- A cross-site request forgery (CSRF) flaw exists as HTTP requests to the Glossary module do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can leverage this vulnerability, causing the victim to edit categories unknowingly. (MSA-15-0003 / CVE-2015-0213)
- An information disclosure vulnerability affects the 'message/externallib.php' script related to missing checks on whether messaging is disabled. This may allow a remote attacker to access messaging-related functions like people search to obtain sensitive information. (MSA-12-0004 / CVE-2015-0214)
- An information disclosure vulnerability affects the 'calendar/externallib.php' script. Through web-services it was possible to get information about calendar events which users did not have permission to view. (MSA-15-0005 / CVE-2015-0215)
- A denial-of-service vulnerability as a result of using a non-optimal regular expression. Specifically, this issue affects the multimedia filter. Attackers can exploit this issue to crash the affected application, denying service to legitimate users. (MSA-15-0007 / CVE-2015-0217)
SolutionUpgrade to Moodle version 2.8.2 or later. If your installation cannot be upgraded to 2.8.x, versions 2.7.4 and 2.6.7 are also patched for these vulnerabilities.