Moodle 2.8.x < 2.8.2 XSS

Medium Nessus Network Monitor Plugin ID 8724

Synopsis

The remote web server is hosting a web application that is vulnerable to a cross-site scripting (XSS) attack.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.8.x prior to 2.8.2 contain a flaw that allows a stored cross-site scripting (XSS) attack. This flaw exists because the 'mod/lesson/db/access.php' script does not validate input to essay feedback when grading lessons before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (MSA-15-0006 / CVE-2015-0216)

Solution

Upgrade to Moodle version 2.8.2 or later.

See Also

http://moodle.org/security

https://moodle.org/mod/forum/discuss.php?d=278616

https://docs.moodle.org/dev/Moodle_2.8.2_release_notes

Plugin Details

Severity: Medium

ID: 8724

Family: CGI

Published: 2015/04/20

Modified: 2016/01/21

Dependencies: 8690

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2015/01/12

Vulnerability Publication Date: 2015/01/19

Reference Information

CVE: CVE-2015-0216

BID: 72657