Moodle 2.5.x < 2.5.7 / 2.6.x < 2.6.4 / 2.7.x < 2.7.1 XSS

Medium Nessus Network Monitor Plugin ID 8722

Synopsis

The remote web server hosts a PHP script that is affected by multiple cross-site scripting vulnerabilities.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.5.x prior to 2.5.8, 2.6.x prior to 2.6.5, and 2.7.x prior to 2.7.1 are vulnerable to multiple cross-site scripting (XSS) vulnerabilities that affect the script 'badges/renderer.php' because it fails to properly sanitize user-supplied badge details from external sources. An attacker can exploit these issues by crafting a badge which contains malicious code that will inject arbitrary HTML or script code in a users browser upon rendering the badge in their browser. (MSA-14-0028 / CVE-2014-3547)

Solution

Upgrade to Moodle version 2.7.1 or later. If your installation cannot be upgraded to 2.7.x, versions 2.6.4 and 2.5.7 are also patched for these vulnerabilities.

See Also

http://moodle.org/security

https://moodle.org/mod/forum/discuss.php?d=264269

http://openwall.com/lists/oss-security/2014/07/21/1

Plugin Details

Severity: Medium

ID: 8722

Family: CGI

Published: 2015/04/20

Modified: 2016/11/23

Dependencies: 8690

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2014/07/14

Vulnerability Publication Date: 2014/07/21

Reference Information

CVE: CVE-2014-3547

BID: 68758