Moodle 2.6.x < 2.6.6 / 2.7.x < 2.7.3 Multiple Vulnerabilities
Medium Nessus Network Monitor Plugin ID 8720
SynopsisThe remote web server is hosting a web application that is vulnerable to multiple attack vectors.
DescriptionThe remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.6.x prior to 2.6.6, or 2.7.x prior to 2.7.3 are exposed to the following vulnerabilities :
- A security bypass flaw exists in 'mod/forum/externallib.php' because it does not verify group permissions. This could allow remote authenticated users to access any forum via the 'forum_get_discussions' web service. (MSA-14-0043 / CVE-2014-7834)
- An information disclosure flaw exists in 'lib/phpunit/bootstrap.php'. By directly accessing an internal file, an unauthenticated user can be shown an error message containing the file system path of the Moodle install. (MSA-14-0044 / CVE-2014-7848)
SolutionUpgrade to Moodle version 2.7.3. If your installation cannot be upgraded to 2.7.x, version 2.6.6 is also patched for these vulnerabilities.