Moodle 2.7.x < 2.7.3 Information Disclosure

Medium Nessus Network Monitor Plugin ID 8718

Synopsis

The remote web server is hosting a web application that is vulnerable to an information disclosure vulnerability.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.7.x prior to 2.7.3 are exposed to an information disclosure flaw because it does not consider the 'moodle/grade:viewhidden' capability before displaying hidden grades, which allows remote authenticated users to obtain sensitive information by leveraging the student role to access the 'core_grades_get_grades' web service. Specifically, this affects the script 'lib/classes/grades_external.php'. (MSA-14-0038 / CVE-2014-7831)

Solution

Upgrade to Moodle version 2.8 or later. If 2.8.x cannot be obtained, 2.7.3 has also been patched for this vulnerability.

See Also

http://moodle.org/security

https://moodle.org/mod/forum/discuss.php?d=275153

http://openwall.com/lists/oss-security/2014/11/17/11

Plugin Details

Severity: Medium

ID: 8718

Family: CGI

Published: 2015/04/20

Modified: 2016/02/05

Dependencies: 8690

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 4.2

Temporal Score: 4

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2014/11/10

Vulnerability Publication Date: 2014/11/17

Reference Information

CVE: CVE-2014-7831

BID: 71123