Moodle 2.7.x < 2.7.1 XSS

Medium Nessus Network Monitor Plugin ID 8717

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple stored cross-site scripting (XSS) attacks.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.7.x prior to 2.7.1 are exposed to the following vulnerabilities :

- A cross-site scripting vulnerability affects the 'failed login' logs. Log entries of failed login attempts were not filtered correctly. (MSA-14-0030 / CVE-2014-3549)

- A cross-site scripting vulnerability affects error messages generated by scheduled tasks were being presented to admins without correct filtering. (MSA-14-0031 / CVE-2014-3550)

Solution

Upgrade to Moodle version 2.7.1 or later.

See Also

http://moodle.org/security

https://moodle.org/mod/forum/discuss.php?d=264271

https://moodle.org/mod/forum/discuss.php?d=264272

Plugin Details

Severity: Medium

ID: 8717

Family: CGI

Published: 2015/04/20

Modified: 2016/01/21

Dependencies: 8690

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2014/07/14

Vulnerability Publication Date: 2014/07/21

Reference Information

CVE: CVE-2014-3549, CVE-2014-3550

BID: 68762, 68761