Moodle 1.9.x < 1.9.12 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8709

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle prior to 1.9.12 are potentially affected by multiple vulnerabilities :

- A security bypass flaw exists in Group/Quiz permissions that could allow a teacher assigned to a particular group to access quiz reports for students in other groups. (MSA-11-0013 / CVE-2011-4288)

- A vulnerability assessment performed by a third party has revealed multiple cross-site scripting (XSS) vulnerabilities. Specifically, these affect URL encoding within the script 'lib/weblib.php'. (MSA-11-0015 / CVE-2011-4290)

Solution

Upgrade to Moodle version 1.9.12 or later.

See Also

http://moodle.org/security

http://www.nessus.org/u?9fbececf

http://www.nessus.org/u?1975e167

https://moodle.org/mod/forum/discuss.php?d=175592

https://moodle.org/mod/forum/discuss.php?d=175590

Plugin Details

Severity: Medium

ID: 8709

Family: CGI

Published: 2015/04/20

Modified: 2016/01/21

Dependencies: 8683

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2011/05/10

Vulnerability Publication Date: 2011/05/11

Reference Information

CVE: CVE-2011-4290, CVE-2011-4288

BID: 73650