Moodle 1.9.x < 1.9.11 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8707


The remote web server is hosting a web application that is vulnerable to multiple attack vectors.


The remote web server hosts Moodle, an open-source course management system. Versions of Moodle prior to 1.9.11 are potentially affected by multiple vulnerabilities :

- Multiple cross-site scripting (XSS) vulnerabilities exist in the media-filter implementation. Specifically, this affects the 'filter/mediaplugin/filter.php' script. A remote attacker could inject arbitrary HTML or scripts via vectors involving Flash Video (FLV) and YouTube videos. (MSA-11-0011 / CVE-2011-4286)

- A cross-site scripting vulnerability exists in '/tag/tag_autocomplete.php' due to lack of input validation. (MSA-11-0003 / CVE-2011-4278)

- A cross-site request forgery vulnerability flaw exists in RSS feeds contained within an RSS block. (MSA-11-0002 / CVE-2011-4133)

- An information disclosure flaw exists in the IMS enterprise enrollment file when placed in the course files area. Specifically, this affects the 'imsenterprise-enrol.xml' file. (MSA-11-0008 / CVE-2011-4283)


Upgrade to Moodle version 1.9.11 or later.

See Also

Plugin Details

Severity: Medium

ID: 8707

Family: CGI

Published: 2015/04/20

Modified: 2016/11/23

Dependencies: 8683

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2011/03/01

Vulnerability Publication Date: 2011/03/01

Reference Information

CVE: CVE-2011-4286, CVE-2011-4283, CVE-2011-4278, CVE-2011-4133

BID: 73628, 73782