MyBB < 1.6.13 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8629

Synopsis

The remote web server is running a PHP application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts MyBulletinBoard, a web-based discussion board application. Versions of MyBB 1.6.x prior to 1.6.13 are potentially affected by multiple issues :

- Prone to a cross-site scripting vulnerability due to the lack of user-sanitized input submitted to the 'keywords' parameter of the '/Upload/search.php' script.(CVE-2014-1840)

- An unspecified flaw in the random string generator which results in insufficient random strings.

- A flaw affecting the language files could allow an attacker to execute arbitrary PHP code.

- A flaw affecting the stylesheets could allow an attacker to execute arbitrary PHP code.

Solution

Upgrade to MyBB 1.6.13 or later.

See Also

http://www.nessus.org/u?cf49e57b

http://www.nessus.org/u?43f50036

http://docs.mybb.com/versions/1.6.13

Plugin Details

Severity: Medium

ID: 8629

Family: CGI

Published: 2015/01/22

Modified: 2016/12/12

Dependencies: 9125

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mybb:mybb

Patch Publication Date: 2014/04/25

Vulnerability Publication Date: 2014/04/25

Reference Information

CVE: CVE-2014-1840

BID: 65344