MyBB 1.8.x < 1.8.2 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8618

Synopsis

The remote web server is running a PHP application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts MyBulletinBoard, a web-based discussion board application. Versions of MyBB 1.8.x prior to 1.8.2 are are potentially affected by multiple issues :

- A SQL injection vulnerability in member.php which could allow remote attackers to execute arbitrary SQL commands via the 'question_id' parameter in a do_register action.(CVE-2014-9240)

- Multiple cross-site scripting vulnerabilities which could allow remote attackers to inject arbitrary web script or HTML via the (1) 'type' parameter to report.php, (2) 'signature' parameter in a do_editsig action to usercp.php, or (3) 'title' parameter in the style-templates module in an edit_template action or (4) 'file' parameter in the config-languages module in an edit action to 'admin/index.php'.(CVE-2014-9241)

Solution

Upgrade to MyBB version 1.8.2 or higher.

See Also

http://www.nessus.org/u?6dd6bdc9

http://www.nessus.org/u?8896bfe5

Plugin Details

Severity: High

ID: 8618

File Name: 8618.prm

Family: CGI

Published: 2015/01/19

Modified: 2016/03/03

Dependencies: 9125

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mybb:mybb

Patch Publication Date: 2014/12/04

Vulnerability Publication Date: 2014/11/14

Reference Information

CVE: CVE-2014-9240, CVE-2014-9241

BID: 71091