MediaWiki < 1.19.23 / 1.22.15 / 1.23.8 / 1.24.1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8611


The remote web server is running a PHP application that is affected by a security bypass and cross-site scripting vulnerability.


In versions older than 1.24.1, 1.22.15 or 1.19.23 or 1.23.8, MediaWiki contains a flaw in API handling which allows an attacker to bypass authentication. This issue occurs when a website includes an allowed domain as part of its name in '$wgCrossSiteAJAXdomains' in API calls. An attacker can exploit this issue to bypass CORS restrictions. Older versions of MediaWiki are also prone to a cross-site scripting vulnerability because 'thumb.php' script fails to properly sanitize user-supplied input when handling wikitext messages before returning it to the users.


Upgrade to MediaWiki version 1.24.1. Alternatively, versions 1.19.23, 1.22.15, and 1.23.8 or later are patched for these vulnerabilities.

See Also

Plugin Details

Severity: Medium

ID: 8611

Family: CGI

Published: 2014/12/29

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium


Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 6.5

Temporal Score: 6


Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Patch Publication Date: 2014/12/24

Vulnerability Publication Date: 2014/12/17

Reference Information

BID: 71775, 71776