Trihedral VTScada 6.5 through 9.x <= 9.1.19, 10.x <= 10.2.21, and 11.x <= 11.1.08 Remote Denial of Service

High Nessus Network Monitor Plugin ID 8609


A vulnerable VTScada server has been detected.


Trihedral VTScada versions 6.5 through 9.1.19, 10.x through 10.2.21, and 11.x through 11.1.08 contain a denial of service vulnerability caused by an integer overflow condition due to inadequately validated user input. A remote and unauthenticated attacker could cause the VTScada server to crash by sending a specially crafted packet to the VTScada server.


Trihedral has released three updated versions of VTScada that resolve this issue: 11.1.09, 10.2.22, and 9.1.20. Upgrade the software per the vendor's recommendations.

See Also

Plugin Details

Severity: High

ID: 8609

Family: SCADA

Published: 2014/12/18

Modified: 2016/01/21

Dependencies: 8578

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 7.5

Temporal Score: 7


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:trihedral:vtscada

Patch Publication Date: 2014/12/04

Vulnerability Publication Date: 2014/12/09

Reference Information

CVE: CVE-2014-9192

BID: 71591