Revive Adserver < 3.1.0 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8607

Synopsis

The remote host running Revive Adserver is prone to multiple vulnerabilities because it is hosting an outdated version.

Description

The remote host is running Revive Adserver, an open source PHP-based Ad serving system. This version of Revive Adserver is vulnerable to the following:

- A denial-of-service vulnerability that occurs in the 'XML-RPC' implementation. Specifically, the issue affects the 'XML/RPC.php' script. (CVE-2014-8875)

- A cross-site scripting vulnerability because Revive fails to properly sanitize user-supplied input. Specifically, this issue affects the 'refresh_page' parameter of the '/www/admin/report-generate.php' script. (CVE-2014-8793)

Solution

Upgrade to Revive Adserver 3.1.0 or later.

See Also

http://www.revive-adserver.com/security/revive-sa-2014-002

http://www.revive-adserver.com/blog/revive-adserver-v3-1-0-released

Plugin Details

Severity: Medium

ID: 8607

Family: CGI

Published: 2014/12/17

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:revive:revive

Patch Publication Date: 2014/12/17

Vulnerability Publication Date: 2014/12/17

Reference Information

CVE: CVE-2014-8793, CVE-2014-8875

BID: 71718, 71721