phpMyAdmin 4.0.x < 4.0.10.5 / 4.1.x < 4.1.14.6 / 4.2.x < 4.2.10.1 Multiple XSS (PMASA-2014-12)

Medium Nessus Network Monitor Plugin ID 8564

Synopsis

The remote web server contains a PHP application that is affected by multiple cross-site scripting vulnerabilities.

Description

Versions of phpMyAdmin earlier than 4.0.10.5, 4.1.14.6, and 4.2.10.1 are unpatched for cross-site scripting vulnerabilities affecting the SQL debug output and server monitor page. These vulnerabilities can be leveraged to steal cookie-based authentication, among other potential attacks, though note that they can only be leveraged by a logged-in user.

Solution

Either upgrade to phpMyAdmin 4.0.10.5, 4.1.14.6, 4.2.10.1 or later, or apply the patches from the referenced links.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2014-12.php

Plugin Details

Severity: Medium

ID: 8564

Family: CGI

Published: 2014/10/25

Modified: 2016/02/29

Dependencies: 9102

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2014/10/21

Vulnerability Publication Date: 2014/10/21

Reference Information

CVE: CVE-2014-8326

BID: 70731