phpMyAdmin 4.0.x < 22.214.171.124 / 4.1.x < 126.96.36.199 / 4.2.x < 188.8.131.52 Multiple XSS (PMASA-2014-11)
Medium Nessus Network Monitor Plugin ID 8542
SynopsisThe remote web server contains a PHP application that is affected by multiple cross-site scripting vulnerabilities.
DescriptionVersions of phpMyAdmin earlier than 184.108.40.206, 220.127.116.11, and 18.104.22.168 are unpatched for cross-site scripting vulnerabilities affecting the table search and table structure pages. These vulnerabilities can be leveraged to steal cookie-based authentication, among other potential attacks, though note that they can only be leveraged by a logged-in user.
SolutionEither upgrade to phpMyAdmin 22.214.171.124, 126.96.36.199, 188.8.131.52 or later, or apply the patches from the referenced links.