phpMyAdmin 4.0.x < 18.104.22.168 / 4.1.x < 22.214.171.124 / 4.2.x < 126.96.36.199 Multiple XSS (PMASA-2014-8, PMASA-2014-9)
Medium Nessus Network Monitor Plugin ID 8408
SynopsisThe remote web server contains a PHP application that is affected by multiple vulnerabilities.
DescriptionVersions of phpMyAdmin earlier than 188.8.131.52, 184.108.40.206, or 220.127.116.11 are unpatched for cross-site scripting vulnerabilities on the following pages:
- The view operations page
- browse table
- ENUM editor
- query charts and table relations pages
Note that these vulnerabilities may only be leveraged by a user who is logged in.
SolutionEither upgrade to phpMyAdmin 18.104.22.168, 22.214.171.124, 126.96.36.199 or later, or apply the patches from the referenced links.