phpMyAdmin 4.0.x < 4.0.10.2 / 4.1.x < 4.1.14.3 / 4.2.x < 4.2.7.1 Multiple XSS (PMASA-2014-8, PMASA-2014-9)

Medium Nessus Network Monitor Plugin ID 8408

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin earlier than 4.0.10.2, 4.1.14.3, or 4.2.7.1 are unpatched for cross-site scripting vulnerabilities on the following pages:

- The view operations page
- browse table
- ENUM editor
- monitor
- query charts and table relations pages

Note that these vulnerabilities may only be leveraged by a user who is logged in.

Solution

Either upgrade to phpMyAdmin 4.0.10.2, 4.1.14.3, 4.2.7.1 or later, or apply the patches from the referenced links.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2014-8.php

http://www.phpmyadmin.net/home_page/security/PMASA-2014-9.php

Plugin Details

Severity: Medium

ID: 8408

Family: CGI

Published: 2014/10/02

Modified: 2016/02/29

Dependencies: 9102

Nessus ID: 77643

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2014/08/17

Vulnerability Publication Date: 2014/08/17

Reference Information

CVE: CVE-2014-5273, CVE-2014-5274

BID: 69268, 69269