Ecava IntegraXor < 3.6.4000.1 Directory Traversal

Medium Nessus Network Monitor Plugin ID 8405

Synopsis

A vulnerable version of Ecava IntegraXor has been detected.

Description

IntegraXor versions prior to 3.6.4000.1 contain a flaw that allows a remote attacker to traverse outside of a restricted path. This issue is due to the 'open' script not properly sanitizing user input, specifically directory traversal style attacks (e.g., ../../) supplied via the 'file_name' parameter. Successful exploitation of this vulnerability would allow an attacker to read arbitrary files.

Solution

Upgrade to IntegraXor version 3.6.4000.1 or later.

See Also

http://www.nessus.org/u?063b0edb

http://www.integraxor.com/blog/integraxor-3-6-scada-security-issue-20101222-0323-vulnerability-note/

https://ics-cert.us-cert.gov/advisories/ICSA-10-362-01

Plugin Details

Severity: Medium

ID: 8405

Family: SCADA

Published: 2014/09/25

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ecava:integraxor

Patch Publication Date: 2010/12/22

Vulnerability Publication Date: 2010/12/24

Reference Information

CVE: CVE-2010-4598

BID: 45535