Ecava IntegraXor < 3.5.3900.10 Buffer Overflow

High Nessus Network Monitor Plugin ID 8404

Synopsis

A vulnerable version of Ecava IntegraXor has been detected.

Description

IntegraXor versions prior to 3.5.3900.10 contain a stack-based buffer overflow reportedly related to the 'save()' method not correctly handling requests larger than 1024 bytes. Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code.

Solution

Upgrade to IntegraXor version 3.5.3900.10 or later.

See Also

http://www.nessus.org/u?063b0edb

http://www.integraxor.com/blog/integraxor-3-5-scada-security-issue-20101006-0109-vulnerability-note/

https://ics-cert.us-cert.gov/advisories/ICSA-10-322-01

Plugin Details

Severity: High

ID: 8404

Family: SCADA

Published: 2014/09/25

Modified: 2016/01/30

Dependencies: 1442

Nessus ID: 51360

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:ND/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ecava:integraxor

Patch Publication Date: 2010/10/14

Vulnerability Publication Date: 2010/12/15

Reference Information

CVE: CVE-2010-4597

BID: 45487