OpenSSH < 6.6 Multiple Remote Restriction Bypass Vulnerability

high Nessus Network Monitor Plugin ID 8169

Synopsis

The remote SSH service may be affected by multiple restriction bypass vulnerabilities.

Description

Versions of OpenSSH server before 6.6 are unpatched for multiple restriction bypass vulnerabilities:

- A vulnerability exists related to wildcard usage in the 'AcceptEnv' configuration setting within sshd_config. This could be leveraged by an attacker to bypass environment restrictions via a specially crafted request.

Note: NNM has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner. (CVE-2014-2532)
- The hash_buffer function in schnorr.c in OpenSSH through 6.4, when Makefile.inc is modified to enable the J-PAKE protocol, does not initialize certain data structures, which might allow remote attackers to cause a denial of service (memory corruption) or have unspecified other impact via vectors that trigger an error condition. (CVE-2014-1692)

Solution

Upgrade to OpenSSH version 6.6 or later.

See Also

https://bugzilla.redhat.com/show_bug.cgi?id=1077843

http://www.openssh.com/txt/release-6.6

Plugin Details

Severity: High

ID: 8169

Family: SSH

Published: 3/24/2014

Updated: 3/6/2019

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:openbsd:openssh:*:*:*:*:*:*:*:*

Patch Publication Date: 3/21/2014

Vulnerability Publication Date: 3/21/2014

Reference Information

CVE: CVE-2014-2532, CVE-2014-1692

BID: 66355, 65230