phpMyAdmin 3.5.x - 4.0.x < 4.0.5 'Header.class.php' Clickjacking Bypass

Medium Nessus Network Monitor Plugin ID 8150

Synopsis

The remote web server contains a PHP application that is affected by a clickjacking vulnerability.

Description

Versions of phpMyAdmin 3.5.x or 4.0.x earlier than 4.0.5 are affected by a clickjacking vulnerability within the 'Header.class.php' script due to insufficient user input sanitation. An attacker could leverage this to bypass the application's clickjacking protection mechanisms.

Solution

Either upgrade to phpMyAdmin 4.0.5 or later, or apply the patches from the referenced link.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2013-10.php

Plugin Details

Severity: Medium

ID: 8150

File Name: 8150.prm

Family: CGI

Published: 2014/03/06

Modified: 2016/11/23

Dependencies: 9102

Nessus ID: 69448

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2013/08/04

Vulnerability Publication Date: 2013/08/04

Reference Information

CVE: CVE-2013-5029

BID: 61804