phpMyAdmin 3.5.x < 3.5.8.2 / 4.0.x < 4.0.4.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8144

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 3.5.x earlier than 3.5.8.2 or 4.0.x earlier than 4.0.4.2 are affected by the following multiple vulnerabilities:

- Numerous input-validation errors exist that could lead to cross-site scripting attacks related to 'version.json', text to link transformations, schema export, SQL queries, setup, chart display, process list, and the logo link. Note that the link transformation issue, PMASA-2013-13 (CVE-2013-5001), only affects the 4.0.x branch. (CVE-2013-4995, CVE-2013-4996, CVE-2013-4997, CVE-2013-5001, CVE-2013-5002)

- Errors exist that could allow full installation path disclosure via error messages. This information could be used in further attacks. (CVE-2013-4998, CVE-2013-4999, CVE-2013-5000)

- Errors in the files 'schema_export.php' and 'pmd_pdf.php' could allow SQL injection attacks.(CVE-2013-5003)

Solution

Either upgrade to phpMyAdmin 3.5.8.2, 4.0.4.2 or later, or apply the patches from the referenced links.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2013-8.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-9.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-11.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-12.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-13.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-14.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-15.php

Plugin Details

Severity: Medium

ID: 8144

File Name: 8144.prm

Family: CGI

Published: 2014/03/05

Modified: 2016/02/29

Dependencies: 9102

Nessus ID: 69184

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2013/07/28

Vulnerability Publication Date: 2013/07/28

Reference Information

CVE: CVE-2013-4995, CVE-2013-4996, CVE-2013-4997, CVE-2013-4998, CVE-2013-4999, CVE-2013-5000, CVE-2013-5001, CVE-2013-5002, CVE-2013-5003

BID: 61510, 61511, 61512, 61513, 61515, 61516, 61919, 61921, 61923

OSVDB: 95787, 95788, 95789, 95790, 95791, 95792, 95793, 95794, 95795, 95796, 95797, 95798