phpMyAdmin 3.5.x < 22.214.171.124 / 4.0.x < 126.96.36.199 Multiple Vulnerabilities
Medium Nessus Network Monitor Plugin ID 8144
SynopsisThe remote web server contains a PHP application that is affected by multiple vulnerabilities.
DescriptionVersions of phpMyAdmin 3.5.x earlier than 188.8.131.52 or 4.0.x earlier than 184.108.40.206 are affected by the following multiple vulnerabilities:
- Numerous input-validation errors exist that could lead to cross-site scripting attacks related to 'version.json', text to link transformations, schema export, SQL queries, setup, chart display, process list, and the logo link. Note that the link transformation issue, PMASA-2013-13 (CVE-2013-5001), only affects the 4.0.x branch. (CVE-2013-4995, CVE-2013-4996, CVE-2013-4997, CVE-2013-5001, CVE-2013-5002)
- Errors exist that could allow full installation path disclosure via error messages. This information could be used in further attacks. (CVE-2013-4998, CVE-2013-4999, CVE-2013-5000)
- Errors in the files 'schema_export.php' and 'pmd_pdf.php' could allow SQL injection attacks.(CVE-2013-5003)
SolutionEither upgrade to phpMyAdmin 220.127.116.11, 18.104.22.168 or later, or apply the patches from the referenced links.