Siemens S7-300 Series PLC CPU Firmware <= 3.2.11 DoS

High Nessus Network Monitor Plugin ID 7225


A Siemens S7-300 programmable logic controller (PLC) has been detected which is vulnerable to a Denial of Service (DoS) attack vector.


Siemens S7-300 PLC central processing units (CPUs) contain an unspecified flaw that may allow a remote attacker to use a specially crafted packet to cause the device to enter defect mode until a cold restart is performed.


Upgrade the firmware to version 3.2.12 or later.

See Also,"

Plugin Details

Severity: High

ID: 7225

File Name: 7225.pasl

Version: 1.0

Family: SCADA

Published: 2016/09/09

Modified: 2016/09/09

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/h:siemens:simatic_s7_300

Patch Publication Date: 2016/08/16

Vulnerability Publication Date: 2016/08/16

Reference Information

CVE: CVE-2016-3949

BID: 91133

OSVDB: 139580