OpenSSH < 4.0 Information Disclosure

low Nessus Network Monitor Plugin ID 701167

Synopsis

The remote SSH server is affected by an information disclosure vulnerability.

Description

The installed version of OpenSSH is prior to 4.0 and is affected by an information disclosure vulnerability due to how the application stores hostnames, IP addresses, and keys in plaintext in the 'known_hosts' file. A local attacker, exploiting this flaw, could gain access to sensitive information that could be used in subsequent attacks.

Solution

Upgrade to OpenSSH version 4.0 or later.

See Also

http://www.openssh.com/txt/release-4.0

Plugin Details

Severity: Low

ID: 701167

Family: SSH

Published: 8/21/2019

Updated: 8/21/2019

Nessus ID: 44075

Risk Information

CVSS v2

Risk Factor: Low

Base Score: 1.2

Temporal Score: 0.9

Vector: AV:L/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.5

Temporal Score: 3.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Patch Publication Date: 3/9/2005

Vulnerability Publication Date: 8/23/2005

Reference Information

CVE: CVE-2005-2666

BID: 89385