OpenSSH < 5.9 Multiple DoS

Medium Nessus Network Monitor Plugin ID 701162

Synopsis

The remote SSH server may be affected by multiple denial of service vulnerabilities.

Description

The version of OpenSSH running on the remote host is prior to version 5.9. Such versions are affected by multiple denial of service vulnerabilities:

- A denial of service vulnerability exists in the gss-serv.c 'ssh_gssapi_parse_ename' function. A remote attacker may be able to trigger this vulnerability if gssapi-with-mic is enabled to create a denial of service condition via a large value in a certain length field. (CVE-2011-5000)
- On FreeBSD, NetBSD, OpenBSD, and other products, a remote, authenticated attacker could exploit the remote_glob() and process_put() functions to cause a denial of service (CPU and memory consumption). (CVE-2010-4755)

Solution

Upgrade to OpenSSH 5.9 or later.

See Also

http://www.openssh.com/txt/release-6.7

http://cxsecurity.com/research/89

http://site.pi3.com.pl/adv/ssh_1.txt/

Plugin Details

Severity: Medium

ID: 701162

Family: SSH

Published: 2019/08/21

Updated: 2019/08/21

Dependencies: 1997

Nessus ID: 17703

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Patch Publication Date: 2011/09/06

Vulnerability Publication Date: 2010/07/07

Reference Information

CVE: CVE-2010-4755, CVE-2011-5000

BID: 54114, 68757