phpMyAdmin 2.11.x < 2.11.9.5 / 3.x < 3.1.3.1 RCE (PMASA-2009-3)

High Nessus Network Monitor Plugin ID 700609

Synopsis

The remote web server contains a PHP application that may allow execution of arbitrary code.

Description

The setup script included with the version of phpMyAdmin installed on the remote host does not properly sanitize user-supplied input to several variables before using them to generate a config file for the application. Using specially crafted POST requests, an unauthenticated, remote attacker may be able to leverage this issue to execute arbitrary PHP code.

Solution

Upgrade to phpMyAdmin version 3.1.3.1 or later. If 3.x cannot be obtained, version 2.11.9.5 has also been patched for this vulnerability.

See Also

https://www.phpmyadmin.net/security/PMASA-2009-3

Plugin Details

Severity: High

ID: 700609

Family: CGI

Published: 2019/04/19

Updated: 2019/04/19

Dependencies: 9102

Nessus ID: 36170

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2009/04/16

Vulnerability Publication Date: 2009/04/16

Reference Information

CVE: CVE-2009-1151

BID: 34236