Grandstream GXV3240 < 1.0.3.219 RCE

critical Nessus Network Monitor Plugin ID 700496
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is using a Grandstream GXV3240 device that is vulnerable to a Remote Code Execution (RCE) attack vector.

Description

The remote host is running a Grandstream GXV3240 device, firmware version prior to 1.0.3.219, and is therefore affected by a remote command execution vulnerability that exists in the 'priority' and 'logserver' parameters. An unauthenticated, remote attacker can exploit them to bypass authentication and execute arbitrary commands with root privileges.

Solution

Upgrade to Grandstream GXV3240 firmware version 1.0.3.219 or later.

See Also

https://www.tenable.com/blog/multiple-remote-code-execution-vulnerabilities-found-in-grandstream-devices

https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920

https://threatpost.com/grandstream-bugs-smbs-attacks/143141

Plugin Details

Severity: Critical

ID: 700496

Family: IoT

Published: 4/5/2019

Updated: 4/6/2019

Dependencies: 700493

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:h:grandstreamnetworks:gxv3240:*:*:*:*:*:*:*:*

Patch Publication Date: 3/22/2019

Vulnerability Publication Date: 3/22/2019

Reference Information

CVE: CVE-2019-10655