Magento Community Edition 2.0.x < 2.0.17 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 700417
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is running an outdated instance of Magento Community Edition (CE) that is affected by multiple attack vectors.

Description

Versions of Magento CE 2.0.x prior to 2.0.17 are affected by multiple vulnerabilities :

- An administrator with limited privileges can create Billing Agreements with embedded cross-site scripting (XSS) elements that can subsequently lead to a stored XSS attack.
- An administrator with limited privileges can insert malicious code in e-mail templates, product attributes, and promo fields creating an opportunity for arbitrary remote code execution.
- An administrator with limited privileges can create a downloadable product that can create an opportunity for arbitrary code execution.
- An administrator with limited privileges can insert injectable code in the 'swatches' feature, creating an opportunity for arbitrary remote code execution.
- An administrator with limited privileges can create a store website that can accept and run arbitrary remote code execution.
- An administrator with limited privileges can delete critical system control files to subsequently gain privilege escalation through the Import History section.
- An administrator with limited privileges can insert a widget block containing malicious code, creating an opportunity for arbitrary remote code execution.
- An administrator with limited privileges can inject malicious code that can cause sensitive files to be deleted. He could then launch a second stage payload that would lead to arbitrary remote code execution.

Solution

Upgrade to Magento CE version 2.0.17 or later.

See Also

https://magento.com/security/patches/magento-2.2.1-2.1.10-and-2.0.17-security-update

Plugin Details

Severity: High

ID: 700417

Family: CGI

Published: 2/19/2019

Updated: 3/6/2019

Dependencies: 9691

Risk Information

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.2

Temporal Score: 7.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:magento:magento:*:*:*:*:*:*:*:*

Patch Publication Date: 11/7/2017

Vulnerability Publication Date: 11/7/2017