Drupal 8.5.x < 8.5.1 RCE

Critical Nessus Network Monitor Plugin ID 700230

Synopsis

The remote server is hosting an outdated installation of Drupal that is vulnerable to a critical remote code execution attack vector.

Description

The version of Drupal installed on the remote server is 8.5.x prior to 8.5.1, and is affected by a flaw in the 'preHandle()' function in 'core/lib/Drupal/Core/DrupalKernel.php' that is triggered as certain parameter keys within HTTP requests are not properly sanitized. This may allow a remote attacker to execute arbitrary code. This issue may be exploited using multiple unspecified attack vectors.

Solution

Upgrade to Drupal 8.5.1 or later.

See Also

https://www.drupal.org/sa-core-2018-002

Plugin Details

Severity: Critical

ID: 700230

Family: CGI

Published: 2018/03/29

Updated: 2019/03/06

Dependencies: 9212

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2018/03/28

Vulnerability Publication Date: 2018/03/27

Reference Information

CVE: CVE-2018-7600

BID: 103534