Drupal 8.5.x < 8.5.1 RCE

critical Nessus Network Monitor Plugin ID 700230
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote server is hosting an outdated installation of Drupal that is vulnerable to a critical remote code execution attack vector.


The version of Drupal installed on the remote server is 8.5.x prior to 8.5.1, and is affected by a flaw in the 'preHandle()' function in 'core/lib/Drupal/Core/DrupalKernel.php' that is triggered as certain parameter keys within HTTP requests are not properly sanitized. This may allow a remote attacker to execute arbitrary code. This issue may be exploited using multiple unspecified attack vectors.


Upgrade to Drupal 8.5.1 or later.

See Also


Plugin Details

Severity: Critical

ID: 700230

Family: CGI

Published: 3/29/2018

Updated: 3/6/2019

Dependencies: 9212

Risk Information


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*

Patch Publication Date: 3/28/2018

Vulnerability Publication Date: 3/27/2018

Reference Information

CVE: CVE-2018-7600

BID: 103534