Drupal 7.x < 7.58 RCE

Critical Nessus Network Monitor Plugin ID 700224


The remote server is hosting an outdated installation of Drupal that is vulnerable to a critical remote code execution attack vector.


The version of Drupal installed on the remote server is 7.x prior to 7.58, and is affected by a flaw in the 'preHandle()' function in 'core/lib/Drupal/Core/DrupalKernel.php' that is triggered as certain parameter keys within HTTP requests are not properly sanitized. This may allow a remote attacker to execute arbitrary code. This issue may be exploited using multiple unspecified attack vectors.


Upgrade to Drupal 7.58 or later.

See Also


Plugin Details

Severity: Critical

ID: 700224

Family: CGI

Published: 2018/03/29

Updated: 2019/03/06

Dependencies: 9211

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2018/03/28

Vulnerability Publication Date: 2018/03/27

Reference Information

CVE: CVE-2018-7600

BID: 103534