MyBB < 1.8.11 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 700070


The remote web server is running a PHP application that is vulnerable to multiple vulnerabilities.


Versions of MyBB (MyBulletinBoard) prior to 1.8.11 are affected by the following vulnerabilities :

- The file 'usercp.php' contains an error that can allow server side request forgery (SSRF) via specially-crafted requests. (CVE-2017-7566)
- An unspecified user-input error can allow cross-site scripting attacks (XSS). (CVE-2017-8103)
- The file 'upload/admin/modules/config/smilies.php' contains a user-input validation error that can allow file disclosure via path traversal. (CVE-2017-8104)


Upgrade to MyBB version 1.8.11 or later.

See Also

Plugin Details

Severity: High

ID: 700070

Family: CGI

Published: 2017/05/02

Updated: 2019/03/06

Dependencies: 9126

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mybb:mybb

Patch Publication Date: 2017/04/04

Vulnerability Publication Date: 2017/04/07

Reference Information

CVE: CVE-2017-7566, CVE-2017-8103, CVE-2017-8104