Moodle 3.1.x < 3.1.5 Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 700010

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 3.1.x prior to 3.1.5 are affected by multiple unspecified flaws that may allow an attacker to have an unspecified impact. No further details have been provided.
- A flaw exists that allows a Cross-Site Scripting (XSS) attack. This flaw exists because the program does not validate input when handling files attached for evidence for prior learning before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that will execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Solution

Upgrade to Moodle version 3.1.5 or later.

See Also

https://docs.moodle.org/dev/Moodle_3.1.5_release_notes

Plugin Details

Severity: Critical

ID: 700010

Family: CGI

Published: 2017/03/20

Updated: 2019/03/06

Dependencies: 9398

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2017/03/13

Vulnerability Publication Date: 2017/03/13

Reference Information

CVE: CVE-2017-2645

BID: 96982