Moodle 3.0.x < 3.0.9 RCE

critical Nessus Network Monitor Plugin ID 700009
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is hosting a web application that is vulnerable to a Remote Code Execution (RCE) attack vector.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 3.0.x prior to 3.0.9 are affected by a flaw that may allow an attacker to execute arbitrary code.

Solution

Upgrade to Moodle version 3.0.9 or later.

See Also

https://docs.moodle.org/dev/Moodle_3.0.9_release_notes

https://moodle.org/mod/forum/discuss.php?d=349419#p1409805

Plugin Details

Severity: Critical

ID: 700009

Family: CGI

Published: 3/20/2017

Updated: 3/6/2019

Dependencies: 9398

Risk Information

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*

Patch Publication Date: 3/13/2017

Vulnerability Publication Date: 3/13/2017

Reference Information

CVE: CVE-2017-2641