PuTTY < 0.63 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6987

Synopsis

The remote host is running a Telnet/SSH client containing multiple potential vulnerabilities.

Description

The remote host is using a vulnerable version of PuTTY or of a PuTTY-based software (eg. PSCP or WinSCP). PuTTY is a Telnet/SSH client built for Linux and UNIX variants as well as Microsoft Windows operating systems. Reportedly PuTTY is affected by a buffer overflow (CVE-2013-4207) that could lead to remote code execution, a buffer underflow (CVE-2013-4206) that can corrupt the heap or cause a denial of service condition, and multiple information disclosure vulnerabilities due to its failure to properly clean the private keys typed by the user from memory during authentication.

Solution

Upgrade to PuTTY 0.63 or higher.

See Also

http://seclists.org/oss-sec/2013/q3/291

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-modmul.html

http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-bignum-division-by-zero.html

http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/private-key-not-wiped.html

Plugin Details

Severity: Medium

ID: 6987

Family: SSH

Published: 2013/08/12

Modified: 2018/09/16

Dependencies: 1968

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:simon_tatham:putty

Patch Publication Date: 2013/08/06

Vulnerability Publication Date: 2013/08/06

Reference Information

CVE: CVE-2013-4206, CVE-2013-4207, CVE-2013-4208, CVE-2013-4852

BID: 61645, 61644, 61649