phpMyAdmin 3.5.x < 3.5.8.1 / 4.x < 4.0.0-rc3 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6933

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 3.5.x prior to 3.5.8.1, or 4.x prior to 4.0.0-rc3 are affected by multiple vulnerabilities :

- A flaw exists in 'preg_replace' method as it fails to properly sanitize arguments, which can be used to for arbitrary code execution. (CVE-2013-3238)
- A security weakness exists in the way that locally saved databases are handled. It is possible that the 'filename_template' parameter can be used to create a file with double extensions. (CVE-2013-3239)
- A flaw exists where the 'what' parameter is not correctly validated, allowing for a local file inclusion. This flaw reportedly affects phpMyAdmin 4.x only. (CVE-2013-3240)
- A flaw exists in the 'export.php' script that allows overwrite of global variables, leading to an unauthorized access vulnerability. This flaw reportedly affects phpMyAdmin 4.x only. (CVE-2013-3241)

Solution

Either upgrade to phpMyAdmin 3.5.8.1 / 4.0.0-rc3 or later, or apply the patches from the referenced link.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2013-2.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-3.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-4.php

http://www.phpmyadmin.net/home_page/security/PMASA-2013-5.php

http://www.waraxe.us/advisory-103.html

Plugin Details

Severity: Medium

ID: 6933

File Name: 6933.prm

Family: CGI

Published: 2013/07/19

Modified: 2016/03/02

Dependencies: 9102

Nessus ID: 66295

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2013/04/24

Vulnerability Publication Date: 2013/04/24

Exploitable With

Metasploit (phpMyAdmin Authenticated Remote Code Execution via preg_replace())

Reference Information

CVE: CVE-2013-3238, CVE-2013-3239, CVE-2013-3240, CVE-2013-3241

BID: 59460, 59461, 59462, 59465