phpMyAdmin 4.0.x < 4.0.4.1 'import.php' Security Vulnerability

Medium Nessus Network Monitor Plugin ID 6917

Synopsis

The remote web server contains a PHP application that is affected by a security vulnerability as a result of improper user input sanitation.

Description

Versions of phpMyAdmin 4.0.0 through 4.0.4 are potentially affected by a remote security vulnerability that lets attackers inject arbitrary GLOBALS variable. The issue occurs because the application fails to properly sanitize user-supplied input submitted to the 'import.php' script. Attackers can exploit this issue to inject arbitrary GLOBALS variables and manipulate any configuration parameters.

Solution

Apply the vendor patches or upgrade to phpMyAdmin 4.0.4.1 or later.

See Also

http://github.com/phpmyadmin/phpmyadmin/commit/012464268420e53a9cd81cbb4a43988d70393c36

http://www.phpmyadmin.net/home_page/security/PMASA-2013-7.php

Plugin Details

Severity: Medium

ID: 6917

File Name: 6917.prm

Family: CGI

Published: 2013/07/09

Modified: 2016/02/29

Dependencies: 9102

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 4.2

Temporal Score: 3.6

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2013/06/30

Vulnerability Publication Date: 2013/06/30

Reference Information

CVE: CVE-2013-4729

BID: 60940

OSVDB: 94738