phpMyAdmin 4.0.x < 'import.php' Security Vulnerability

Medium Nessus Network Monitor Plugin ID 6917


The remote web server contains a PHP application that is affected by a security vulnerability as a result of improper user input sanitation.


Versions of phpMyAdmin 4.0.0 through 4.0.4 are potentially affected by a remote security vulnerability that lets attackers inject arbitrary GLOBALS variable. The issue occurs because the application fails to properly sanitize user-supplied input submitted to the 'import.php' script. Attackers can exploit this issue to inject arbitrary GLOBALS variables and manipulate any configuration parameters.


Apply the vendor patches or upgrade to phpMyAdmin or later.

See Also

Plugin Details

Severity: Medium

ID: 6917

File Name: 6917.prm

Family: CGI

Published: 2013/07/09

Modified: 2016/02/29

Dependencies: 9102

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 4.2

Temporal Score: 3.6


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2013/06/30

Vulnerability Publication Date: 2013/06/30

Reference Information

CVE: CVE-2013-4729

BID: 60940

OSVDB: 94738