Mozilla Thunderbird < 17.0.5 Multiple Vulnerabilities

critical Nessus Network Monitor Plugin ID 6736
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host has an email client installed that is vulnerable to multiple attack vectors.


Versions of Mozilla Thunderbird prior to 17.0.5 are affected by the following security issues :

- Remote memory-corruption vulnerabilities in the browser engine that could lead to arbitrary code execution. Successful exploits may allow an attacker to execute arbitrary code in the context of the user running the affected application. Failed exploit attempts will result in a denial-of-service condition. (CVE-2013-0788, CVE-2013-0789, CVE-2013-0790)
- A local privilege-escalation vulnerability exists due to a buffer-overflow in Mozilla Maintenance Service. An attacker requires local file system access to exploit this issue. Exploiting this issue allows attackers to execute arbitrary code with elevated privileges. (CVE-2013-0799)
- The applications are prone to a denial-of-service vulnerability due to an an out-of-bounds write condition in the Cairo graphics library. (CVE-2013-0800)
- A local privilege-escalation vulnerability exists due to an error when using Mozilla Updater. Specifically, the issue occurs when the malicious 'DLL' file is placed in a specific location on the local system before the Mozilla Updater is run. (CVE-2013-0797)
- A remote memory-corruption vulnerability exists in WebGL rendering. Specifically, the issue occurs because the applications attempts to free memory that has not previously been allocated. The vulnerability only affects Linux users who have Intel Mesa graphics drivers. (CVE-2013-0796)
- A security-bypass vulnerability due to an error when cloning a node through the 'cloneNode()' method. An attacker can exploit this issue to bypass System Only Wrappers (SOW) and the same origin policy. (CVE-2013-0795)
- A cross-site scripting vulnerability exists because of an error related to a 'baseURI' of a page in the history. An attacker can exploit this issue to spoof the URL displayed in the address bar while displaying a different page and execute script code. (CVE-2013-0793)


Upgrade to Thunderbird 17.0.5 or later.

See Also

Plugin Details

Severity: Critical

ID: 6736

Family: SMTP Clients

Published: 4/4/2013

Updated: 3/6/2019

Dependencies: 5558

Nessus ID: 65806

Risk Information


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:*

Patch Publication Date: 4/3/2013

Vulnerability Publication Date: 4/2/2013

Reference Information

CVE: CVE-2013-0788, CVE-2013-0793, CVE-2013-0795, CVE-2013-0796, CVE-2013-0797, CVE-2013-0799, CVE-2013-0800, CVE-2013-0789, CVE-2013-0790

BID: 58826, 58819, 58821, 58825, 58831, 58836, 58837, 58823, 58824, 58827