Dropbear SSH Server < 2012.55 RCE

High Nessus Network Monitor Plugin ID 6338

Synopsis

The remote ssh service is affected by a remote code execution (RCE) attack vector.

Description

Dropbear, an SSH server, is installed on the remote host. Versions of Dropbear SSH prior to 2012.55 contain a flaw that might allow an attacker to run arbitrary code on the remote host with root privileges if they are authenticated using a public key and command restriction is enforced.

Solution

Upgrade to Dropbear SSH 2012.55 or later.

See Also

https://matt.ucc.asn.au/dropbear/CHANGES

https://secure.ucc.asn.au/hg/dropbear/rev/818108bf7749

https://www.mantor.org/~northox/misc/CVE-2012-0920.html

Plugin Details

Severity: High

ID: 6338

Family: SSH

Published: 2012/02/29

Modified: 2017/03/28

Dependencies: 700029, 3059

Nessus ID: 58183

Risk Information

Risk Factor: High

CVSSv2

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS3#AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:matt_johnston:dropbear

Reference Information

CVE: CVE-2012-0920

BID: 52159