phpMyAdmin 3.4.x < 3.4.5 Multiple XSS (PMASA-2011-14)

Low Nessus Network Monitor Plugin ID 6026

Synopsis

The remote web server contains a PHP application that is affected by multiple cross-site scripting vulnerabilities.

Description

Versions of phpMyAdmin 3.4.x earlier than 3.4.5 are potentially affected by multiple cross-site scripting vulnerabilities :
- The data used in the row content display after inline editing is not properly sanitized before it is passed back to the browser.
- The data passed in as table, column, and index names is not properly sanitized before it is passed back to the browser.
A remote attacker may use these issues to cause arbitrary code to be executed in a user's browser, to steal authentication cookies and the like.

Solution

Apply the vendor patches or upgrade to phpMyAdmin 3.4.5 or later.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2011-14

Plugin Details

Severity: Low

ID: 6026

Family: CGI

Published: 2011/09/23

Modified: 2018/09/16

Dependencies: 9102

Nessus ID: 56379

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.5

Temporal Score: 2.9

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 3

Temporal Score: 2.8

Vector: CVSS3#AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2011/09/14

Vulnerability Publication Date: 2011/09/14

Reference Information

BID: 49648