phpMyAdmin 3.3.x < / 3.4.x < Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5995


The remote web server contains a PHP application that is vulnerable to multiple attack vectors.


Versions of phpMyAdmin 3.3.x earlier than and 3.4.x earlier than are potentially affected by multiple vulnerabilities :

- A cross-site scripting vulnerability exists in the table Print view. (PMASA-2011-9)

- A local file inclusion vulnerability can be exploited via a specially crafted MIME-type transformation parameter. (PMASA-2011-10)

- In the 'relational schema' code a parameter is not sanitized before being used to concatenate a class name which could lead to a local file inclusion or code execution. (PMASA-2011-11)

- It is possible to manipulate the PHP superglobals (including SESSION) using some of the Swekey authentication code. (PMASA-2011-12)


Upgrade to phpMyAdmin,, or later.

See Also

Plugin Details

Severity: Medium

ID: 5995

Family: CGI

Published: 2011/07/28

Modified: 2018/09/16

Dependencies: 9102

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 6.3

Temporal Score: 5.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2011/07/23

Vulnerability Publication Date: 2011/07/23

Reference Information

CVE: CVE-2011-2642, CVE-2011-2643

BID: 48874