phpMyAdmin 3.3.x < / 3.4.x < Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5985


The remote web server contains a PHP application that is vulnerable to multiple attack vectors.


Versions of phpMyAdmin 3.3.x earlier than and 3.4.x earlier than are potentially affected by multiple vulnerabilities :

- It is possible to manipulate the PHP session superglobal usig some of the Swekey authentication code. (PMASA-2011-5)

- An unsanitized key from the Servers array is written in a comment of the generated config, which could allow an attacker to close the comment and inject code. (PMASA-2011-6)

- It is possible to use a null byte to truncate the pattern string which would allow an attacker to inject the /e modifier causing the pre_replace function to execute its second argument as PHP code. (PMASA-2011-7)

- An issue exists in the MIME-type transformation code, which allows for directory traversal. (PMASA-2011-8)


Upgrade to phpMyAdmin,, or later.

See Also

Plugin Details

Severity: Medium

ID: 5985

Family: CGI

Published: 2011/07/14

Modified: 2018/09/16

Dependencies: 9102

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 6.3

Temporal Score: 5.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2011/07/07

Vulnerability Publication Date: 2011/07/07

Reference Information

CVE: CVE-2011-2505, CVE-2011-2506, CVE-2011-2507, CVE-2011-2508

BID: 48563