phpMyAdmin 3.3.x < 3.3.10.1 / 3.4.x < 3.4.1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5930

Synopsis

The remote web server contains a PHP application that is vulnerable to multiple attack vectors.

Description

Versions of phpMyAdmin 3.3.x earlier than 3.3.10.1 and 3.4.x earlier than 3.4.1 are potentially affected by multiple vulnerabilities :

- It is possible to create a crafted table name that could lead to a cross-site scripting attack. (PMASA-2011-3)

- It is possible to redirect to an arbitrary, untrusted site, leading to a possible phishing site. (PMASA-2011-4)

Solution

Upgrade to phpMyAdmin 3.3.10.1, 3.4.1, or later.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2011-3

http://www.phpmyadmin.net/home_page/security/PMASA-2011-4

Plugin Details

Severity: Medium

ID: 5930

File Name: 5930.prm

Family: CGI

Published: 2011/02/15

Modified: 2016/02/29

Dependencies: 9102

Nessus ID: 54630, 55023

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2011/02/11

Vulnerability Publication Date: 2011/02/11

Reference Information

BID: 47943, 47945