phpMyAdmin 2.x < 2.11.11.3 / 3.x < 3.3.9.2 SQLi (PMASA-2011-2)

Medium Nessus Network Monitor Plugin ID 5797

Synopsis

The remote web server contains a PHP application that is vulnerable to a SQL-injection attack.

Description

Versions of phpMyAdmin earlier than 2.11.11.3 / 3.3.9.2 are potentially affected by a SQL-injection vulnerability, because the application makes it possible to create a bookmark which would be executed unintentionally by other users.

Solution

Upgrade to phpMyAdmin 2.11.11.3, 3.3.9.2, or later.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2011-2

Plugin Details

Severity: Medium

ID: 5797

File Name: 5797.prm

Family: CGI

Published: 2011/02/15

Modified: 2016/02/29

Dependencies: 9102

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2011/02/11

Vulnerability Publication Date: 2011/02/11

Reference Information

CVE: CVE-2011-0987

BID: 46359