Bugzilla < 3.2.9 / 3.4.9 / 3.6.3 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5700

Synopsis

The remote web server is hosting an application that is vulnerable to multiple attack vectors.

Description

The remote web server is hosting Bugzilla, a web-based bug tracking application.

Versions of Bugzilla 3.2.x earlier than 3.2.9, 3.4.x earlier than 3.4.9, and 3.6.x earlier than 3.6.3 are potentially affected by multiple vulnerabilities :

- By inserting a certain string into a URL, it is possible to inject both headers and content to any browser that supports "Server Push". (CVE-2010-3172)

- The Charts system generates graphs with predictable names into the 'graphs/' directory, which can also be browsed to see its contents. (CVE-2010-3764)

- YUI 2.8.1 is vulnerable to a cross-site scripting vulnerability in certain .swf files.

Solution

Upgrade to Bugzilla 3.2.9, 3.4.9, 3.6.3 or later.

See Also

http://www.bugzilla.org/security/3.2.8

Plugin Details

Severity: High

ID: 5700

File Name: 5700.prm

Family: CGI

Published: 2010/11/05

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 50599

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/11/02

Vulnerability Publication Date: 2010/11/02

Reference Information

CVE: CVE-2010-3172, CVE-2010-3764

BID: 44618