phpMyAdmin 3.x < 3.3.6 XSS

Medium Nessus Network Monitor Plugin ID 5652

Synopsis

The remote web server contains a PHP application that is vulnerable to a cross-site scripting attack.

Description

Versions of phpMyAdmin earlier than 3.3.6 are potentially affected by a cross-site scripting vulnerability via error messages in PHP backtrace.

Solution

Upgrade to phpMyAdmin 3.3.6 or later.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2010-6.php

Plugin Details

Severity: Medium

ID: 5652

Family: CGI

Published: 2010/08/31

Modified: 2016/02/29

Dependencies: 9102

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2010/08/30

Vulnerability Publication Date: 2010/08/30

Reference Information

BID: 42874