Drupal Ubercart Module < 5.x-1.10 / 6.x-2.4 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5634

Synopsis

The remote web server is hosting a web application that is affected by an authentication bypass vulnerability.

Description

The remote web server hosts a Drupal install that uses the Ubercart, an e-commerce module for Drupal CMS.

Versions of Ubercart earlier than 5.x-1.10 / 6.x-2.4 are potentially affected by multiple vulnerabilities :

- The 2Checkout gateway module does not properly verify payment notification information. Note that this module must be enabled for the Drupal install to be affected.

- The Paypal module's WPS payment method does not properly verify the payment notification information. Note that this module must be enabled for the Drupal install to be affected.

- The Ubercart Cart Links module is vulnerable to both an Access Bypass and Cross Site Request Forgery where a malicious user can trick other users into adding or removing items from their cart and add items to a cart which are not published on the site. Note that this module must be enabled for the Drupal install to be affected.

Solution

Upgrade to Drupal Ubercart Module 5.x-1.10 / 6.x-2.4 or later.

See Also

http://drupal.org/node/880396

Plugin Details

Severity: High

ID: 5634

Family: CGI

Published: 2010/08/12

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/08/12

Vulnerability Publication Date: 2010/08/12

Reference Information

BID: 42389