Drupal OpenID module < 5.x-1.5 Authentication Bypass Vulnerability

High Nessus Network Monitor Plugin ID 5632


The remote web server is hosting a web application that is affected by an authentication bypass vulnerability.


The remote web server hosts a Drupal install that uses the OpenID module, a module that allows users to authenticate via OpenID.

Versions of Drupal OpenID module earlier than 5.x-1.5 are potentially affected by an authentication bypass vulnerability because the application fails to implement all the required verifications from the OpenID 2.0 protocol. A remote attacker, exploiting this flaw, could gain unauthorized access to the affected Drupal install.


Upgrade to Drupal OpenID module 5.x-1.5 or later.

See Also


Plugin Details

Severity: High

ID: 5632

Family: CGI

Published: 2010/08/12

Modified: 2018/09/16

Dependencies: 1442

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.8


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2010/08/12

Vulnerability Publication Date: 2010/08/12

Reference Information

CVE: CVE-2010-3091, CVE-2010-3685, CVE-2010-3686

BID: 42388