Drupal Devel module < 6.x-1.22 Cross-Site Scripting Vulnerability

Medium Nessus Network Monitor Plugin ID 5631

Synopsis

The remote web server is hosting a web application that is vulnerable to a cross-site scripting attack.

Description

The remote web server hosts a Drupal install that uses the Devel module, a performance logging component.

Versions of the Drupal Devel module earlier than 6.x-1.22 are potentially affected by a cross-site scripting vulnerability because the application fails to properly sanitize URLs comprised of node paths. A remote attacker with the ability to to add URL aliases could exploit this flaw to execute arbitrary script code in a user's browser.

Solution

Upgrade to Drupal Devel module 6.x-1.22 or later.

See Also

http://drupal.org/node/874132

http://drupal.org/node/882460

Plugin Details

Severity: Medium

ID: 5631

File Name: 5631.prm

Family: CGI

Published: 2010/08/17

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/08/04

Vulnerability Publication Date: 2010/08/04

Reference Information

CVE: CVE-2010-3022

BID: 42231

OSVDB: 66889