Mantis 1.2.x < 1.2.2 Cross-Site Scripting Vulnerability

High Nessus Network Monitor Plugin ID 5619

Synopsis

The remote web server is hosting a web application that is vulnerable to a cross-site scripting attack.

Description

The remote web server is hosting Mantis, an open source bugtracking application written in PHP. Versions of Mantis 1.2.x are potentially affected by a cross-site scripting vulnerability. The application does not properly validate inline attachments before rendering them. An attacker, exploiting this flaw, could execute arbitrary script code in a users browser.

Solution

Upgrade to Mantis 1.2.2 or later.

See Also

http://www.mantisbt.org/blog/?p=113

http://www.mantisbt.org/bugs/changelog_page.php?version_id=110

Plugin Details

Severity: High

ID: 5619

File Name: 5619.prm

Family: CGI

Published: 2010/08/03

Modified: 2016/01/15

Dependencies: 8680

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/07/29

Vulnerability Publication Date: 2010/07/29

Reference Information

BID: 42119